Registrieren  •  Login 
  
 
im Forum


 FAQ   Mitgliederliste   Benutzergruppen   Teamseite   Suchen 

Mail Problem

 
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
killerbees19
Administrator & Rennleitung
Administrator & Rennleitung



OC-Nickname: KB19
Südafrika Team South Africa

Anmeldedatum: 09.05.2006
Geschlecht: Männlich
Alter: 29 Jahre
Beiträge: 13930
Wohnort: Wien

BeitragVerfasst am: 04.01.2008, 11:54    Titel: Mail Problem

Hallo Leute.

Man sollte meinen, dass es solche Probleme nicht gibt Laughing
Bitte nicht lachen: Hat jemand eine Idee warum die zweite Mail nicht versendet werden kann?

PHP-Code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
<?php

// Test E-Mail senden

// Welche Version?
if(isset($_GET['new']))
{
    
// Funktioniert
    
$header "From: forum#happytec.at\n";
    
$header .= "Reply-To: forum#happytec.at\n";
    
$header .= "Content-type: text/html\n";
    
$header .= "X-Priority: 3\n";
    
$header .= "X-MSMail-Priority: Normal\n";
}
else
{
    
// Funktioniert _nicht_
    
$header "From: forum#happytec.at\n";
    
$header .= "Reply-To: forum#happytec.at\n";
    
$header .= "Content-type: text/html\n";
    
$header .= "X-Priority: 3\n";
    
$header .= "X-MSMail-Priority: Normal\n";
    
$header .= "Bcc: ich#happytec.at\n"// <--- Die Problemzeile
    
$header .= "X-AntiAbuse: User_id - 3\n";
    
$header .= "X-AntiAbuse: Username - killerbees19\n";
}

var_dump(mail('TEST <admin#happytec.at>''TEST - '.date('H:i'), '<h1>TEST</h1>'$header));

?>

Das @ habe ich hier im Forum durch ein Raute Zeichen ersetzt, damit die Spambots die Adresse nicht finden Wink
Falls jemand einen Vorschlag hat, warum gerade die Bcc-Zeile plötzlich seit dem Serverwechsel nicht mehr funktioniert, nur herein damit. Im Moment quält sich schon der Support von meinem Hoster damit herum, aber vielleicht liegt es an einem ganz einfachen Problem.


MfG Christian
_________________
Nach oben
Benutzer-Profile anzeigen killerbees19 ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden Website dieses Benutzers besuchen
rami
Mitglied
Mitglied



Anmeldedatum: 07.10.2006
Geschlecht: Männlich
Beiträge: 759

BeitragVerfasst am: 04.01.2008, 12:26    Titel:

keine ahnung aber probier mal \r\n statt \n.
Nach oben
Benutzer-Profile anzeigen rami ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
killerbees19
Administrator & Rennleitung
Administrator & Rennleitung



OC-Nickname: KB19
Südafrika Team South Africa

Anmeldedatum: 09.05.2006
Geschlecht: Männlich
Alter: 29 Jahre
Beiträge: 13930
Wohnort: Wien

BeitragVerfasst am: 04.01.2008, 12:45    Titel:

Das habe ich schon probiert, half nichts.
Auch kein Zeilenumbruch am Ende brachte nichts.


MfG Christian
_________________
Nach oben
Benutzer-Profile anzeigen killerbees19 ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden Website dieses Benutzers besuchen
NoMoKeTo
Ehemaliger
Ehemaliger



Anmeldedatum: 13.07.2006
Geschlecht: Männlich
Beiträge: 1019
Wohnort: NRW

BeitragVerfasst am: 04.01.2008, 13:18    Titel:

Verwende die mailklasse von phpguru.org !
Sie gibt dir viele tolle möglichkeiten udn vielleicht taucht der Fehler dan auch nicht mehr auf Wink
_________________
Ich spreche Esperanto und lerne auf diesem Weg tolle Leute kennen - weltweit!
Nach oben
Benutzer-Profile anzeigen NoMoKeTo ist derzeit offline Private Nachricht senden Website dieses Benutzers besuchen
lupus
Mitglied
Mitglied



Anmeldedatum: 30.09.2007
Geschlecht: Männlich
Beiträge: 85
Wohnort: Karlsruhe

BeitragVerfasst am: 04.01.2008, 13:40    Titel:

Hallo.
Frage ist, ob du bei deinen Tests eine Unterschiedliche email-Adresse für "to" und "bcc" verwendest? Wenn beide identisch sind, verwirft php den BCC automatisch. Ansonsten funktioniert das Script bei mir zumindest ohne Probleme Wink
Nach oben
Benutzer-Profile anzeigen lupus ist derzeit offline Private Nachricht senden Website dieses Benutzers besuchen
killerbees19
Administrator & Rennleitung
Administrator & Rennleitung



OC-Nickname: KB19
Südafrika Team South Africa

Anmeldedatum: 09.05.2006
Geschlecht: Männlich
Alter: 29 Jahre
Beiträge: 13930
Wohnort: Wien

BeitragVerfasst am: 04.01.2008, 13:55    Titel:

Ich habs mit den gleichen und mit unterschiedlichen ausprobiert. Das Script funktionierte bisher auch immer, erst seit dem Serverwechsel geht es nicht mehr.


MfG Christian
_________________
Nach oben
Benutzer-Profile anzeigen killerbees19 ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden Website dieses Benutzers besuchen
killerbees19
Administrator & Rennleitung
Administrator & Rennleitung



OC-Nickname: KB19
Südafrika Team South Africa

Anmeldedatum: 09.05.2006
Geschlecht: Männlich
Alter: 29 Jahre
Beiträge: 13930
Wohnort: Wien

BeitragVerfasst am: 04.01.2008, 22:06    Titel:

Jetzt funktioniert es wieder Very Happy


MfG Christian
_________________
Nach oben
Benutzer-Profile anzeigen killerbees19 ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden Website dieses Benutzers besuchen
NoMoKeTo
Ehemaliger
Ehemaliger



Anmeldedatum: 13.07.2006
Geschlecht: Männlich
Beiträge: 1019
Wohnort: NRW

BeitragVerfasst am: 04.01.2008, 22:45    Titel:

...das problem war nämlich, ... ?
_________________
Ich spreche Esperanto und lerne auf diesem Weg tolle Leute kennen - weltweit!
Nach oben
Benutzer-Profile anzeigen NoMoKeTo ist derzeit offline Private Nachricht senden Website dieses Benutzers besuchen
killerbees19
Administrator & Rennleitung
Administrator & Rennleitung



OC-Nickname: KB19
Südafrika Team South Africa

Anmeldedatum: 09.05.2006
Geschlecht: Männlich
Alter: 29 Jahre
Beiträge: 13930
Wohnort: Wien

BeitragVerfasst am: 05.01.2008, 10:56    Titel:

Ich habe nichts am Script geändert. Mein Hoster muss wohl etwas an der Serverkonfiguration geändert haben Very Happy

UPDATE: Laut meinem Hoster wurde nichts geändert.
Sehr komischer Fehler, aber hauptsache er ist weg Very Happy


MfG Christian
_________________


Dieser Beitrag wurde insgesamt 1 mal geändert. Zuletzt von killerbees19.
Nach oben
Benutzer-Profile anzeigen killerbees19 ist derzeit offline Spielerprofile bei SC:Special Bewerben anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht teilnehmen.
Du kannst Dateien in diesem Forum nicht hochladen.
Du kannst Dateien in diesem Forum nicht herunterladen.

 

Alle Zeiten sind GMT + 2 Stunden (Sommerzeit)
Aktuelles Datum und Uhrzeit: 03.04.2020, 03:45
Nach oben
Valid HTML 4.01 Transitional
Valid CSS!
Software based on work from the phpBB-Group  •  Deutsche Übersetzung von phpBB.de

netcup - Internetdienstleistungen
 
 
[ happytec.at | forum.happytec.at | blog.happytec.at | esports.happytec.at | event.happytec.at ]